Nuevas funciones en Excel SI.CONJUNTO

Hasta ahora anidábamos funciones SI cuando necesitábamos obtener varios resultados en función de la prueba lógica. Por ejemplo dependiendo de la Referencia escrita en la celda E5 debemos obtener el descuento correspondiente en la celda F5. En este ejemplo con la ref3 el descuento a devolver será 30%, es decir el que le corresponde en la celda C7.

Si.ConjuntoCon la función SI escribiríamos la siguiente fórmula anidada: =SI(E5=B5;C5;SI(E5=B6;C6;SI(E5=B7;C7))) “como ejemplo aparece en la celda F6”

Desde Febrero de 2016 con las actualizaciones de Excel nos encontramos la función SI.CONJUNTO, dentro de Fórmulas > Lógicas, y su sintaxis es SI.CONJUNTO(Logical_Test1;Value_if_true1;Logical_Test2;Value_if_true2;Logical_Test3;Value_if_true3)

=SI.CONJUNTO(E5=B5;C5;E5=B6;C6;E5=B7;C7)

Con esta función el anidado será más sencillo de realizar e interpretar, acortando la fórmula cuando hay muchos datos. En este ejemplo con el argumento Logical_test1 comparamos el valor escrito en la celda E5 con la celda B5 ( E5=B5 ), si el resultado es VERDADERO obtendremos la celda de al lado C5 argumento Value_if_true, ,,, y así sucesivamente.

En el ejemplo no está contemplado la prueba falsa, con esta función puedes usar al final del argumento, ;VERDADERO;”” de esta forma cuando no cumpla ninguna de las condiciones devolverá vacío. Recuerda que lo que pongas entre comillas si es un texto lo devuelve la función, para números no hace falta poner comillas.
=SI.CONJUNTO(E5=B5;C5;E5=B6;C6;E5=B7;C7;VERDADERO;””)

 

 

24 comentarios en “Nuevas funciones en Excel SI.CONJUNTO

  1. hola, sabes que funcion me puede servir o como puedo anidar la funcion para escojer un resultado al comparar dos columnas? por ejemplo si quiero hacer una comparación de si en una columna me sale X y en columna b=Y el resultado es XY…

  2. Hola, necesito hacer una condicional pero si una fecha esta entro de un rango.

    Gracias.
    HORA
    06:15:00 a.m. 06:44:00 a.m. DIGA OK
    06:45:00 a.m. 07:00:00 a.m. DIGA ALERTA
    07:15:00 a.m. 07:30:00 a.m. DIGA ERROE

    • Hola Diana, puedes utilizar la función Y para crear los intervalos. (Cambia mayor igual y menor por los símbolos)
      =SI.CONJUNTO(Y(D3 mayor o igual C5;D3 menor o igual D5);”OK”;Y(D3 mayor o igual C6;D3 menor o igual D6);”ALERTA”;Y(D3 mayor o igual C7;D3 menor o igual D7);”ERROR”)
      En D3 escribes la hora y las celdas:
      C5=06:15 D5=6:44
      C6=06:45 D6=7:00
      C7=07:00 D5=7:30
      Gracias por seguir nuestro blog http://www.exceltrucos.com , comparte en Facebook

    • Hola puedes usar la función O dentro de un SI, por ejemplo =SI(O(celda=”x”;celda=”y”;celda=”z”);”his”;SI(O(celda=”d”;celda=”f”;celda=”g”);”leu”;””))

      Un ejemplo de un condicional puedes repasarlo en :Ejemplo de Función SI

      Gracias por seguir ExcelTrucos y por compartir en Facebook 😉

  3. Pingback: Funciones lógicas SI – O | Excel Trucos

  4. NECESITO UNA FORMULA QUE AL ESCRIBIR EL DATO Y ESTAR EN EL RANGO ME HAGA ESTO

    0-50 DIGA 1
    50.01-75 DIGA 2
    75.01-100 DIGA 3
    100.01-125 DIGA 4
    125.01-150 DIGA 5
    150.01-200 DIGA 6
    200.01-300 DIGA 7
    300.01 O MAYOR DIGA 8

  5. MMMM…está bien solo q un punto negativo sería q no cuenta con un ValorSiFalso , dificultando la parte final , tendríamos que hacer un SI.ERROR para subsanarlo

    • Cierto Jairo, en el ejemplo no está contemplado el falso, con esta función puedes usar al final del argumento, ;VERDADERO;”” de esta forma cuando no cumpla ninguna de las condiciones devolverá vacío.
      =SI.CONJUNTO(E5=B5;C5;E5=B6;C6;E5=B7;C7;VERDADERO;””)
      También lo podrías corregir con SI.ERROR como dices.

  6. Hola, tengo una duda, no sé cómo formular lo siguiente: si una celda pone “NO”, entonces que escriba el valor de la celda C3; pero si las celdas A1, B1,C1 son <5, entonces que escriba el valor de la celda C4; o si las celdas A1 y B1 son <5, entonces que escriba el valor de la celda C4; o si las celdas B1 y C1 son <5, entonces que escriba el valor de la celda C4. Esta es la fórmula que he hecho siguiendo la información que ha escrito arriba pero me da error:
    =SI.CONJUNTO(DP95="NO";DE95;(DO95;DQ95;DS95)<5;DX95;(DO95;DQ95)<5;DX95;(DQ95;DS95)<5;DX95)
    ¿Me podría ayudar? MUCHAS GRACIAS

    • Hola María, para comparar varias celdas con un valor u otra celda debes usar las funciones Y , O por ejemplo O(DO95;DQ95;DS95)<5, estas funciones devuelven VERDADERO o FALSO y permiten evaluar dentro de la prueba lógica.

      Gracias por seguir ExcelTrucos.com

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google photo

Estás comentando usando tu cuenta de Google. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

Conectando a %s