Control de Vencimientos con la función SI y FECHANUMERO

En alguna ocasión habréis intentado utilizar la función lógica SI  (“IF” en inglés) para evaluar fechas. Por ejemplo, tenemos fechas de vencimientos de facturas, y queremos crear una columna donde nos diga si la fecha de factura está vencida, cuando la fecha es menor a la fecha de hoy, si es un vencimiento próximo cuando la fecha es antes de final del año 2017 y un vencimiento largo plazo si la factura vence después de 1 de enero de 2018.

Para hacer este tipo de cálculos se debe usar la función FECHANUMERO ,  “DATEVALUE” en inglés, de forma que nuestro cálculo para la celda B2 quedaría de la siguiente forma:(1)

=SI(A2<HOY();”VENCIDO”;SI(A2<FECHANUMERO(“31/12/2017″);”PROXIMO”;”LARGO PLAZO”))

Excel Ayuda FECHANUMERO

Excel no reconoce la fecha como tal, dentro de la función SI y la interpreta como texto, por lo que se debe usar FECHANUMERO.

 

 

6 comentarios en “Control de Vencimientos con la función SI y FECHANUMERO

  1. Buen dia , yo estoy ingresando esta formula, y me arroja un error de NOMBRE?
    =SI(B2-B3E6,”VENCIDO”,”DENTRO DE PLAZO”)

    B2 ES MI FECHA DE HOY , B3 LOS DIAS “GARANTIA” ANTES DE SU VENCIMIENTO (7) , Y E6 LA FECHA DE VENCIMIENTO DE FACTURA,,
    como puedo resolver el error que marca?

      • Hola buena tarde saludos… traté de acoplar su formula con mi caso pero no lo pude lograr, mi caso es: programo pago de facturas cada viernes después de 30 días según la fecha de factura. hay ocasiones en que los 30 días se cumplen en viernes entonces ese día la pago pero por ejemplo si los 30 días se cumplen en sábado entonces la pago hasta el viernes siguiente… podría ayudarme por favor? gracias.

      • Hola Moises, lo podrías hacer con una prueba lógica SI anidada, donde averigües el día de vencimiento y según este sea sumes los días necesarios para que lo mueva a viernes.
        =SI(DIASEM(A1+30;2)=1;A1+30+4;SI(DIASEM(A1+30;2)=2;A1+30+3;SI(DIASEM(A1+30;2)=3;A1+30+2;SI(DIASEM(A1+30;2)=4;A1+30+1;SI(DIASEM(A1+30;2)=6;A1+30+6;SI(DIASEM(A1+30;2)=7;A1+30+5;A1+30))))))
        Gracias por seguir ExcelTrucos.com 😉

  2. Buen día, me podrían ayudar.

    Tengo esta formula para determinar el añejamiento de las facturas en nuestra cartera de clientes, funciona pero deseo cambiarle AHORA por una fecha especifica, trato de hacerlo pero me manda error.

    =SI(E3>AHORA(),”current”,SI(E3>(AHORA()-30),”1-30″,SI(E3>(AHORA()-60),”31-60″,SI(E3>(AHORA()-90),”61-90″,SI(E3>(AHORA()-120),”91-120″,SI(E3>(AHORA()-150),”121-150″,SI(E3>(AHORA()-180),”151-180″,”>180″)))))))

    Agradecería mucho su ayuda.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google photo

Estás comentando usando tu cuenta de Google. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

Conectando a %s