Funciones lógicas SI – O

En una pregunta reciente en la entrada SI.CONJUNTO, necesitaban en función de los datos de una celda obtener un resultado.

Es decir, si la celda contiene una x o una y o una z queremos obtener el código “leu”en otra celda, si la celda contiene una d o f o g obtendremos “leu”, y si no contiene nada o el resto de letras queremos obtener vacío. En mis cursos siempre insisto que ante una fórmula que contenga una prueba lógica lo mejor es escribir en un papel ésta con los SI, O Y que se necesite. Por ejemplo SI juan tiene 20 o 21 o 22 años entonces tiene un 20% de Dto.

Pruebla lógica Excel SI O excel funcion

En Excel, el nombre de la función siempre va al principio, por lo tanto para este ejemplo escribiríamos SI(O(EdadJUAN=20;EdadJUAN=21;EdadJUAN=22);20%) . La función O es una prueba lógica que evalúa cada uno de los argumentos y si alguno de ellos es Verdadero entonces devuelve Verdadero, por lo tanto si EdadJUAN=20 o 21 o 22 obtendremos un Verdadero. Lo metemos dentro de una prueba lógia SI y obtendremos el resultado de éste, es decir un 20% cuando cumpla alguna de las condiciones.

Pruebla lógica Excel SI O excel funcion

Ahora lo aplicamos a nuestro ejemplo y el resultado sería: =SI(O(B4=”x”;B4=”y”;B4=”z”);”his”;SI(O(B4=”d”;B4=”f”;B4=”g”);”leu”;””)). En este caso cuando no se cumpla obtendremos vacío en la celda, en Excel esto se consigue con doble comillas “”

Es importante conocer las Funciones Y O en Excel (AND OR). Si te ha gustado el post comparte en Facebook

Anuncios

2 comentarios en “Funciones lógicas SI – O

  1. Hola, como estas? estoy algo confundido con una formula.. quiero calcular en una celda nueva que me permita identificar si un cliente tiene dualidad, es decir, si nos compran “Al Detal y Al Mayor”, y también poder identificar solo los que nos compran “Solo Detal” y solo los que nos compran “Solo Al Mayor”. El ejemplo es algo así:

    A2= Cliente A
    A3= Cliente A
    A4= Cliente B
    A5= Cliente C
    A6 = Cliente D
    A7 = Cliente D

    B2= Al Detal

    B3= Al Mayor

    B4= Al Mayor

    B5= Al Detal

    B6= Al Detal

    B7 = Al Detal

    C2 = (Es la celda donde quiero identificar el status, para el cliente A
    deberia ser “Al Detal y Al mayor” y así sucesivamente…)

    Muchas gracias, saludos

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

Conectando a %s