Corregir #N/A devuelto con la función BuscarV

En un post anterior BuscarV utilizando tablas en Excel pudimos aprender a utilizar Tablas en Excel y aplicar la función BuscarV.

Pero qué ocurre cuando buscamos un dato como Valor buscado y éste no existe en la tabla Matriz buscar en ? Por ejemplo la referencia «R23» o «R»

Función Si.ErrorPueden pasar dos cosas, que en el argumento Ordenado de la función BuscarV no hayamos puesto nada o VERDADERO, como es el ejemplo de R23 que localizaría el valor más próximo R2, (recuerda que escribiendo FALSO en este argumento encontraremos la coincidencia exacta y devolvería #N/A),o el caso de la Referencia R que devuelve el error #N/A ya que no encuentra nada aproximado ni que coincida.

Pues bien, la función SI.ERROR permitiría corregir este error y mostrar como resultado de la fórmula, vacío «» o un texto por ejemplo con las palabras «No existe».

La sintaxis es : =SI.ERROR(valor;valor_si_error) , es decir el primer argumento será la función BUSCARV, ya que si ésta encuentra el valor debe dar la solución, pero si no lo encuentra pasa al segundo argumento y es en éste donde podemos poner lo que queramos que devuelva.

Función Si.ErrorRecuerda que en este ejemplo trabajamos con tablas no con celdas, por lo tanto en la función BuscarV usamos @Referencia que es el campo de la tabla (naranja) y T_Datos es la tabla (gris) con las Referencias, Nombres y Precios. BuscarV utilizando tablas en Excel

=SI.ERROR(BUSCARV([@Referencia];T_Datos;2;FALSO);»No existe») –> en el caso del Nombre devuelve «No existe», ( importante FALSO en BUSCARV )

=SI.ERROR(BUSCARV([@Referencia];T_Datos;3;FALSO);»») –> en el caso del Precio devuelve «»

Utiliza esta función para mejorar visualmente por ejemplo los informes, en versiones antiguas de Excel no existía y se usaba una función SI con una función ESERROR

16 comentarios sobre “Corregir #N/A devuelto con la función BuscarV

Agrega el tuyo

  1. hola , alguien me puede ayudar con un error N#A pero lo raro es que el valor si esta en la base a buscar, por que me vota este errror , como solucionarlo

      1. A mi también me sucede lo mismo, el valor si está en la vector, ya lo intenté con valor antes del número buscado y tampoco me sale.

  2. Hola ayuda por favor, tengo el mismo problema, me da error y el valor buscado existe. no se como solucionarlo, inclusive copie la tabla en el mismo libro para ver si asi funcionaba y nada.

  3. hola, me trae erróneo el valor buscado. Justamente me trae en valor de la celda anterior. o en su defecto si le doy falso en algunas ocasiones me tira error !! nunca me paso, estoy Justo armando un informe 😦

  4. Hola, tuve este mismo problema y lo solucione de la siguiente manera;

    Me fui a la herramienta buscar y seleccionar/remplazar

    En buscar le puse un espacio, en remplazar no le puse nada. Este error se da en base de datos muy extensas y al tener espacios en las celdas da error para ciertas formulas… dejare mi correo para cualquier duda

    bastian.guerrero.ayala@gmail.com

    Saludos amigos de exceltrucos!!

  5. Buen dia Yo tengo el caso con una tabla pequeña, utilizo la funcion BUSCARV y se que los datos estan alli, de los cuales necestio me devuelva el valor que esta en la columna 2 (orden) pero cuando termino la funcion me devuelve el mensaje de error #N/A

    Ejemplo
    =BUSCARV(G2,A1:D21,2,0) donde en la G2 tengo el dato a buscar y quiero que me devuelva el valor que esta en la columna 2 de la matriz. pero cuando termino, me devuelve el mensaje #N/A

    1. Hola Victor muchas veces devuelve #N/A porque el tipo de datos es diferente, es decir el valor buscado es texto y el encontrado es número, también puede ocurrir que haya un espacio al final del valro, o que haya algún carácter oculto. Copia y pega el mismo el dato buscado y encontrado en dos celdas y en otra pon una celda = a la otra ( =B3=C3) si devuelve FALSO comprobarás que es diferente.
      BuscarV suele tener este tipo de incidencias, gracias por seguir ExcelTrucos.com

Responder a Abel Cancelar la respuesta

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Salir /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Salir /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Salir /  Cambiar )

Conectando a %s

Crea un sitio web o blog en WordPress.com

Subir ↑

A %d blogueros les gusta esto: