BUSCARX, un BUSCARV a la izquierda

Por fin, Excel 2022 añade algunas funciones nuevas, muy esperadas algunas de ellas como por ejemplo BUSCARX.

BUSCARX, resuelve el problema que desde hace mucho tiempo hemos solucionado con las funciones como Índice, Coincidir, etc., el problema era buscar un valor donde la columna de búsqueda está en cualquier posición de una tabla y el resultado en cualquier columna a la izquierda de esta.

La sintaxis de la función añade nuevas opciones de búsqueda y resultado con los nuevos parámetros.

=BUSCARX(valor_buscado; matriz_buscada; matriz_devuelta; [si_no_se_encuentra]; [modo_de_coincidencia]; [modo_de_búsqueda]) 

En el ejemplo que mostramos a continuación, buscamos el producto 2250 (1) en la columna D (2), y queremos obtener la cantidad vendida que le corresponde en la columna C (3)

La función BUSCARX añade nuevos argumentos que le dan un potencial de búsqueda aún más grande, por ejemplo [si no encuentra], en caso de no encontrar la coincidencia devolverá un mensaje con un texto.

=BUSCARX(H3;D3:D17;C3:C17;»no encontrado»)

El [modo de coincidencia] con BUSCARV es 0 (falso) exacto, 1 (verdadero) aproximado, ahora en BUSCARX añade -1 para encontrar el siguiente elemento más pequeño (si buscas el código 1990 en el ejemplo encontrará el 1950) o 1 para el valor más grande (encontrará 2000). Con 2 para localizar un valor si solo conocemos parte de su código, por ejemplo si escribimos a19?? nos encontrará el código a1900, si escribimos a1* encontrará el código primero que comience por a19.

=BUSCARX(H3;D3:D17;C3:C17;»no encontrado»;-1) –> 1950

=BUSCARX(H3;D3:D17;C3:C17;»no encontrado»;1) –>2000

También añade el [modo de búsqueda] -1 para localizar valores de abajo a arriba, os dejamos una tabla con la ayuda.

[si_no_se_encuentra] OpcionalSi no se encuentra una coincidencia válida, devolver el texto [if_not_found] que proporcione. Si no se encuentra una coincidencia válida y falta [if_not_found], #N/A se devuelve.
[modo_de_coincidencia] OpcionalEspecifique el tipo de coincidencia:
0: coincidencia exacta. Si no se encuentra ninguno, devolver #N/A. Este valor es el predeterminado.
-1: coincidencia exacta. Si no se encuentra ninguna, devolver el siguiente elemento más pequeño.
1: coincidencia exacta. Si no se encuentra ninguna, devolver el siguiente elemento más grande.
2: una coincidencia comodín donde *, ? y ~ tienen significado especial.
[modo_de_búsqueda] OpcionalEspecifique el modo de búsqueda que se usará:
1: realizar una búsqueda empezando por el primer elemento. Este valor es el predeterminado.
-1: realizar una búsqueda inversa empezando por el último elemento.
2: realizar una búsqueda binaria que se base en que lookup_array se ordene en orden ascendente. Si no está ordenada, se devolverán resultados no válidos.
-2: realizar una búsqueda binaria que se base en que lookup_array se ordene en orden descendente. Si no está ordenada, se devolverán resultados no válidos.
Información sacada de Microsoft Support

Puedes aprender más sobre BUSCARV en nuestra entrada BuscarV utilizando tablas en Excel. Comparte esta entrada para dar a conocer la nueva función.

Un comentario sobre “BUSCARX, un BUSCARV a la izquierda

Agrega el tuyo

Deja una respuesta

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Salir /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Salir /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Salir /  Cambiar )

Conectando a %s

Crea un sitio web o blog en WordPress.com

Subir ↑

A %d blogueros les gusta esto: