Invertir datos de una Columna DESREF – INDICE

En este ejemplo vamos a  mostrar con fórmulas cómo podemos invertir os datos de una columna, es decir el último dato de ésta debe ser el primero y viceversa.

invertircolumn

Con la función DESREF podemos obtener el resultado, =DESREF($B$23;-((FILA(B5)-FILA($B$4))-1);0)

Si la analizamos por partes ((FILA(B5)-FILA($B$4))-1) obtenemos un resultado de 0,  por lo tanto la función DESREF quedaría DESREF($B$23;0;0) es decir el valor de la ceda B23. Los argumentos de esta función son referencia, fila y columna.

Al arrastrar esta fórmula la siguiente celda será DESREF($B$23;-1;0) por lo tanto obtendremos el valor de una fila  menos de B23 “M19” y así sucesivamente.

Con la función INDICE desde una matriz los solucionamos, en este ejemplo los datos de la columna B –> $B$4:$B$23, sólo debemos indicar la fila que queremos de esa matriz.

=INDICE($B$4:$B$23;FILA($B$23)-FILA(B5)+1)

Si la analizamos por partes con FILA($B$23)-FILA(B5)+1 obtenemos 20 , luego  INDICE($B$4:$B$23;20) como resultado nos dará el último valor de la matriz.

Si arrastramos el resultado irá cambiando  en cada fila de 20 a 19, 18 …

Si quieres usar la función DESREF debes modificar en la fórmula la última celda de la columna B23, y las filas de tus datos.

Si quieres usar la función INDICE debes modificar en la fórmula la matriz  y las filas de tus datos.

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s