Funciones Entero y Texto para dar formato a datos de temperatura

En este ejemplo tenemos una tabla con un registro de temperaturas por horas que  el sistema nos da sin formato.

Queremos aplicar formato a la temperatura de manera que el valor entero lo muestre con grados, por ejemplo 10 deber aparecer como 10 º sin decimales.

El valor con decimales debe aparecer en decimales con grados, por ejemplo 15,59 -> 15,59 º

Para resolver esta necesidad en una columna nueva podríamos utilizar la fórmula:

=SI(B3=0;TEXTO(B3;»0 º»);SI(B3=ENTERO(B3);TEXTO(B3;»# º»);TEXTO(B3;»0,00º»)))

B3=ENTERO(B3) Evalúa si la celda que contiene el dato es un entero, si es así devolverá VERDADERO, en cuyo caso le aplicamos formato con la función TEXTO(B3;»# º»)

En caso de no ser entero el formato con decimales será TEXTO(B3;»0,00º»)

B3=0;TEXTO(B3;»0 º») El primer argumento de la fórmula lo utilizamos para dar formato al valor 0 grados.

Función TEXTO-ENTERO

Deja una respuesta

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Salir /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Salir /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Salir /  Cambiar )

Conectando a %s

Crea un sitio web o blog en WordPress.com

Subir ↑

A %d blogueros les gusta esto: