Formato Condicional para Días Festivos

En esta entrada, veremos cómo aplicar un FORMATO CONDICIONAL que marque con un color las fechas que sean FESTIVOS.

Cómo ejemplo utilizaremos una tabla donde tenemos fechas de finalización de proyectos durante el 2014.

FC Festivos1

Necesitamos en otra hoja por ejemplo tener una tabla con los días festivos de nuestra comunidad o nacionales, para poderla utilizar con la función BUSCARV. Las dos son tablas de datos, con un nombre aplicado, esto nos facilitará tener rangos dinámicos y llamar a las tablas en las funciones.

FC Festivos2

El siguiente paso es en la columna C de la tabla de proyectos averiguar si es festivo o domingo. Con la función BUSCARV averiguamos si es festivo el dato de la Fecha Fin, en caso de no serlo ésta devolverá un #N/A. Para conseguir que nos dé vacío en este caso utilizaremos la función SI.ERROR con el segundo argumento “” . Ya sólo nos quedaría averiguar si es Domingo, y eso lo hacemos con la prueba lógica SI.

Prueba a escribir la función el orden descrito, verás que resulta más sencillo interpretarla ya que puedes ir viendo los resultados de cada paso. Recuerda al ser una tabla los agumentos de las fórmulas que llaman a celdas en vez de ser B5 será el nombre del campo [@[Fecha Fin]].

SI.=SI(DIASEM([@[Fecha Fin]];2)=7;”Domingo”;SI.ERROR(BUSCARV([@[Fecha Fin]];T_2014_F_Festivos_CAM;3;0);””))

FC Festivos3

Ahora vamos a aplicar el formato condicional, para ello selecciona los datos de Fecha Fin y crea una Nueva Regla con Fórmula, recuerda lo que tenemos que buscar es un VERDADERO dentro de ésta para que funcione el Formato Condicional, por eso igualamos B5.

=BUSCARV(B5;’Fiestas 2014 CAM’!$A$1:$C$15;1;0)=B5

FC Festivos4

Selecciona los datos del campo Festivo y aplica el mismo formato condicional si quieres que pinte esta también.

También puedes pintar los Domingos con un formato condicional, revisa el post:

https://exceltrucos.wordpress.com/2013/04/30/funcion-diasem/

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s